Friday, May 9, 2008

HPUX NetApp add and grow file system

Basic process for resizing a file system using the HP-UX LVM and NetApp storage.
1. Create a new LUN on the filer to add to the LVM volume group and map it to the HP-UX host.
filer> lun create -t hpux -s 100g /vol/vol1/oraserv1.lun
filer> lun map /vol/vol1/oraserv1.lun oraserv
lun map: auto-assigned oraserv=1
2. Run commands on the HP-UX host to recognize the LUN and make it available to LVM.
# ioscan -fnC disk
# ioinit -i
# sanlun lun show -p
# pvcreate /dev/dsk/c4t0d1
The "sanlun" command is used to determine the path for the new LUN.
3. Add the new LUN to an existing volume group.
# vgextend vg01 /dev/dsk/c4t0d1
4. Use the Network Appliance attach kit to configure the PVlinks multipathing.
# ntap_config_paths
5. Extend the logical volume.
# lvextend -L 144 /dev/vg01/lvol1
6. If the OnlineJFS license and package are not installed, unmount the file system.
# umount /u01
Note: The command "swlist -l bundle grep JFS" will determine whether OnlineJFS is
installed.
7. Extend the file system.
For systems without OnlineJFS:
# extendfs /dev/vg01/lvol1
For systems with OnlineJFS:
# fsadm -b 147456 /u01
Note: The value 147456 is the size 144 from step 5 multiplied by 1024 to convert it to megabytes.
8. If the file system was unmounted in step 6, remount the file system.
# mount /dev/vg01/lvol1 /u01

No comments:

UNIX: How to print column nicely using printf

[user@hostfwnms1-oam tmp]# cat b.sh printf "%-26s %-19s %-8s %-8s %-s %-s\n" HOSTNAME IP PING SNMPWALK 0-ok 1-fail for i in `cat n...